Login, login failure

Apr 21, 2009 at 5:11 PM
What rights are needed to pass the login prompt?
Coordinator
Apr 21, 2009 at 9:15 PM
You should only need to have Read permissions on the site collection where you invoke the web service.  for example, let's say you have site collection hosted under a url like http://servername/sites - you may find that you don't have permissions to cal the web service at the root - so entering http://servername/ into the conneciton dialog fails, but if you try http://servername/sites/somesitethatyouhaveaccessto will succeed.  HTH.
Apr 30, 2009 at 10:28 PM

Hi,

    Looks like a useful tool... I am trying to run the utility on the server with SharePoint installed on it.   I seem to keep getting a "An error occurred: Attempted to perform an unauthorized operation" when I try to connect to the "search.asmx".   My instance is MOSS.  However if try to connect to the spsearch.asmx, I don't get an error, but I don't get much further than that.   None of my scopes, or managed properties are detected.

Thanks in advance...  Any help is appreciated.

Look forward to using the tool, once I'm over this hump  :-|

Cheers,
spYder

Coordinator
May 4, 2009 at 10:32 PM

"unauthorized operation" likely stems from a lack of permissions for the client user account at the url endpoint you are trying to connect to.

Here's a post that speaks to this:
http://blogs.msdn.com/jingmeili/archive/2007/05/31/how-to-display-current-user-s-full-name-email-and-other-info-in-infopath.aspx

If trying to connect at the site url of various other sites still doesn't let things work, check to ensure that the domain user account that you are using to run the SharePointSearchServiceTool with is listed among the users granted permission to the SSP’s web app (Full Read should be enough).  Permission can be directly granted to the user account, or indirectly via AD security group membership.

In SharePointSearchServiceTool enter the url of the SSP web app to directly connect to it (the url will be something like http://<yourserver>:<sspwebappportnumber>/ssp/admin )

Jun 30, 2009 at 4:07 PM

IF you are using "Anonymous access" in SharePoint 2007 you will get this error.

You need to turn off "Anonymous access" ONLY on the search.asmx in the IIS Manager, while the site has "Anonymous access" turned on.

This will cause the calls to search.asmx to be made with the AppPool credentials.